Our purpose is to support owners in their use and maintenance of the Porsche 928 and to foster camaraderie among owners throughout the world.
Welcome, Guest
Username: Password: Remember me
Welcome to the 928 Owners Club Forum!

Tell us and our members who you are, what you like and why you became a member of this site.
We welcome all new members and hope to see you around a lot!

TOPIC: tach and odometer stopped working

tach and odometer stopped working 07 May 2020 16:45 #21195


  • Posts:6
  • chriswpman's Avatar
  • chriswpman
  • Junior Forum Member
  • OFFLINE
  • Karma: 0
Took my 1987 S4 to a specialist garage to have a Power steering leak fixed, they replaced a hose and cleaned up the area. We noticed that the tach was not working they asked I bring it back another time and they will see if they did something to it. Havent had time to do so they are 35 miles away) Since then I have discovered that the odometer stopped working at the same time plus some of the various system warning lights on the Tach side of the dash no longer work. Is it possible they did something to cause all this at once???
The administrator has disabled public write access.

tach and odometer stopped working 10 May 2020 10:38 #21196


  • Posts:264 Thank you received: 15
  • Rich928's Avatar
  • Rich928
  • Moderator
  • OFFLINE
  • Karma: 4
I cannot see any relation between replacing power steering hoses with speedometer/tach issues ... there is nothing up front on the driver side of the engine compartment involved with the tach/speedo.

Sometimes totally unrelated items happen at the same time. My poor mechanic has to explain this often to customers.

The tach/speedo issue could be something as simple as a lose connector at the bottom of the instrument cluster. This generation of Porsche 928 has a flex circuit that connects all the items in the instrument cluster. Removal and inspection may yield the answer.
Rich
Membership Chairman
Charter Member
1993 928 GTS Cover Girl
1987 928 S4
1979 928 5-speed rescue
1979 928 5-liter track beast
The administrator has disabled public write access.

tach and odometer stopped working 13 May 2020 06:32 #21203


  • Posts:2
  • amotif's Avatar
  • amotif
  • New Forum Member
  • OFFLINE
  • Karma: 0
Check the wiring to 14 pin connector under the hood on the passenger side.It has a tendency to deteriorate. I have a 86 that I am rebuilding the engine I found the wiring harness that runs from the 14 pin connector across the front of the engine was burned, before I found this I had the same problem. I replaced all of my instrements with late model counterparts.
wining.jpg
The administrator has disabled public write access.
Moderators: Rich928, mm928, billvvOC
Time to create page: 0.962 seconds