Our purpose is to support owners in their use and maintenance of the Porsche 928 and to foster camaraderie among owners throughout the world.
Welcome, Guest
Username: Password: Remember me

TOPIC: Has Anyone Put A 89 Engine IN 86 Car ?

Has Anyone Put A 89 Engine IN 86 Car ? 11 Jun 2016 14:57 #19062


  • Posts:3
  • Dragonrob's Avatar
  • Dragonrob
  • New Forum Member
  • OFFLINE
  • Karma: 0
Hi I am new to this forum. I have installed a 89 engine and harness, computers in my 86 928 I was wondering if someone else has done this and if they can give me some tips on what needs to be done with the harness to make it work I would appreciate any help and advice I can get. Thanks Rob.
The administrator has disabled public write access.

Has Anyone Put A 89 Engine IN 86 Car ? 30 Jun 2016 13:22 #19091


  • Posts:995 Thank you received: 9
  • Kiln_Red's Avatar
  • Kiln_Red
  • Moderator
  • OFFLINE
  • Karma: 3
If you have the engine harness, EZK and LH 2.3 modules and their respective harnesses, then this should be a plug-n-play. Where are you finding a snag?
The administrator has disabled public write access.

Has Anyone Put A 89 Engine IN 86 Car ? 30 Jun 2016 13:26 #19092


  • Posts:995 Thank you received: 9
  • Kiln_Red's Avatar
  • Kiln_Red
  • Moderator
  • OFFLINE
  • Karma: 3
For future reference, I would suggest to start this sort of topic in the Technical Discussion Forum where I would expect you might have better luck with suggestions.
The administrator has disabled public write access.

Has Anyone Put A 89 Engine IN 86 Car ? 30 Jun 2016 14:46 #19093


  • Posts:3
  • Dragonrob's Avatar
  • Dragonrob
  • New Forum Member
  • OFFLINE
  • Karma: 0
I put in the 89 harness and computers and I have not been able to get spark or fuel injection to work I don't know why it won't work. I am at the point of giving up I traced wire's that needed power and connected them and still no luck if I knew it would not have worked I would have went with a 86 engine. Some people on rennlist said they knew how but never said anything else so I have just left it sit for now.
The administrator has disabled public write access.

Has Anyone Put A 89 Engine IN 86 Car ? 30 Jun 2016 14:55 #19094


  • Posts:995 Thank you received: 9
  • Kiln_Red's Avatar
  • Kiln_Red
  • Moderator
  • OFFLINE
  • Karma: 3
Dragonrob wrote:
I put in the 89 harness and computers and I have not been able to get spark or fuel injection to work I don't know why it won't work. I am at the point of giving up I traced wire's that needed power and connected them and still no luck if I knew it would not have worked I would have went with a 86 engine. Some people on rennlist said they knew how but never said anything else so I have just left it sit for now.

There is a 2-pin plug (1 green & 1 white wire) that sometimes is forgotten about during engine R&R jobs. This is from the EZK and it must be plugged in to have spark. Make sure that the connectors aren't pinned behind the CE panel and that the plug isn't disconnected. I've seen this a couple of times. The male and female connectors should be easily located at or around the CE panel.
Last Edit: 30 Jun 2016 14:58 by Kiln_Red.
The administrator has disabled public write access.
Moderators: mm928
Time to create page: 0.604 seconds